After stumbling into this problem, I changed the relevant method names in the parent class to the "elegant" terms ("retrieve", "select", "search") and the names in the sub-classes to the "obvious" terms ("find", "select"). But even this got too hairy. So I changed the names of the parent methods to "db_select", "db_fetch" etc and left the sub-classes alone.

I don't really need parent:: much anymore.

Wade.