IWETHEY v. 0.3.0 | TODO
1,095 registered users | 0 active users | 1 LpH | Statistics
Login | Create New User
IWETHEY Banner

Welcome to IWETHEY!

New Would you prefer I did this by e-mail Bug report?
Went to login today.
Blink.. no "Logged in as ___"
Went to this forum (no LRPDs natch)
Hit New Topic: got login box!
Accepted with "Logged in yada"
Backed out and reloaded [shift] - "Logged in as __" vanished!
Ditto other forumibuses.

Writing this under the first dance.

Oh - might want to nuke the "ashton2" login?
I took back Ashton - there's apparently another disreputable character on EZ who stole mine first.. hence the 2 there (thought at first you had transferred our logins etc.)

Well, let's see where this odd login takes me next: IF it also makes a difference that I now post this message ??

Ashton
New Nope.. Zope-zapped, zonally
ie No LRPDs, no "Logged in as ___".

Ditto if I use link to start page and drill down.

Zope zealously zaps zero-log-limbo zymurgies - zestily!


Zsa Zsa would be zychotic!





ZAshton
*Zot*
New Er.. no "Mark Forum Read" etc. As follows..
New Zomezing zomewat zimilarr --
Arrive at z.iwethey.org/forums.

Press "login".

Get the quick (browser-generated) login box. Fill in the data. Submit.

*flash*

No LRPDs, no "Logged in as..."

Select a forum.

Bingo! "Logged in as Ric Locke (User)". LRPDs in appropriate places.

Post.

Return to main forums pages. Still shows "Logged in...". Lots of LRPDs.

Opera 3.62 over Win 3.1 (Howdy, Ashton!) over DR DOS 7.03 (So I'm an antique. Sue me)

Regards,
Ric
New This is a familiar problem.
Opera 3.x was very aggressive with caching. You will probably want to experiment with the page ageing settings in Opera. 10 minutes is what I use.

Wade.

"All around me are nothing but fakes
Come with me on the biggest fake of all!"

New Agree with Wade.
Sounds like caching issues.

I'll step up the user-selectable caching stuff a bit in the TODO list.
Regards,

-scott anderson
New One more time:
I nuked both caches, and Nav 4.5 that was running (though I didn't log off ISP -- somehow takes over a minute for DUN to convince other end that I be an OK member, maybe sending 2 requests for authentication..)

As before, I tried to login: -blink- + nada. No LRPDs or image boxes on main page. Select Suggestions. Maybe 15-25 seconds? Get THIS forum with LRPD image boxes (yes, the cache was succesfully incinerated). (I leave images off, mostly), "Show image" brings back the li'l feller. On all posts.

BUT no option for Mark read, Showall/Show New.

When I then selected Reply (LH side of Ric's post) THEN got the sign-in menu. It went away and Right Here Now above - I see "Logged in as Ashton". I suspect that this too shall pass - *after I POST this little note of zaftig zaniness*

Er - I also presume you aren't setting cookies, still-not ?? (though I haven't yet figured out the bizarre W98SE "cookie" folder with another hated index.dat encrypted file within). I suppose I can try setting THAT R/O after I have the few needed routine cookies in a clean mt file (?)

Running ZAlarm and WWasher - OK elsewhere = "accept all cookies" in Nav: 'cept what Hi Security in ZA deems ugly, and crumbles anyway.

Anyway - still in zlimbo here; it know who I be, let's me post - but won't play nicely for MarkRead and all.. I'll switch off WW when I save this - maybe later nuke proxy, kill both ZA and WW = but That didn't work with whatever was my earlier problem last week. After 3 W-98/ 98 lite installs in last few days MY CACHE has been overwritten... with all \ufffd \ufffd \ufffd \ufffd \ufffd \ufffd's




Ashton

PS - It did work normally say ~Sat? I can live with the inconvenience til you get around to sleuthing. Note too that I have TWO login names just now w/ same PW - though I haven't yet tried to use 'ashton2' after doing Ashton' -- could this be putting Zope in a zephyrous zither of jump-indirect-to self?

Ashton
ashton2
Klaatu the Younger - after Dad's resuscitation wore off and Gort had to..
New I haven't changed anything...
Since Saturday, that would affect logins.

It's simple Basic Auth.

It's either a cache-issue, or something with the ZoneAlarm or WWasher -- I can't think of anything else that would cause that.

zIWETHEY doesn't use cookies at all. Something is preventing your browser from holding its auth information for the whole site.
Regards,

-scott anderson
New Ok - any clue re where to sleuth?
I'll later log off ISP and nuke both ZA and WW and both NS caches too.

But I have no lore to imagine where / how sign-in auths are 'stored' by the browser's guts. Nor a ctachy title which might merit a box in NS's Prefs list.

Thanks for the info.


Ashton
(So it can't be my dupe posting names?)
New Er *something* remembers I'm logged in - as THIS post
demonstrates. I can go to another forum and post or return here as now and post THIS. No login box appeared and - my Logged in as Ashton appears L. of the login link right now. It will disappear after I post this!

I'll try the Tecra next. (Hmm - what's the timeout for inactivity after login? Also -- no logout?)



A.
Can we say evanesce
New OK going to test forum: Tecra logs in.
Same ISP just logged off from, natch.

What mode can a browser toggle, which finds message at login link unpalatable - then handles the forced login (via 'Reply' command) -- though next tells system to forget I'm logged, and forget to ask for menu for Mark Read yada ??

AFTER the (successful) post!?


Fuck You George Boole
New What's going on (I think)
It sounds to me like your proxy server is only sending auth info when the info is actually requested. Most browsers (NS 4, IE, Opera) will send auth info to a site once they have a domain request no matter if they get another request or not. It becomes a sort of cookie. Some browsers, like recent Mozilla builds, will only send the auth info when the HTTP server actually requests it., or for any page under the page the browser authenticated for.

Example: if I have a protected page /forums/forms/content/editReply, and that is the first page for which Mozilla sends auth info, Mozilla will never send auth info for any unprotected page above editReply in the directory hierarchy (eg. /forums/render/showContent). The problem manifests as being logged in for replies, but "not logged in" for unprotected pages. The display pages are unprotected so people can browse anonymously.

How zIWETHEY authentication works:

The only protected pages are the user pref pages and the reply pages. When a user logs in, zIWETHEY redirects the login to a page at the top of the /forums hierarchy in order to trick the browser into always sending the auth info.

I think your proxies might be somehow foiling my hack for Mozilla, because that's exactly the same behavior I got in Mozilla before I added the redirect hack.
Regards,

-scott anderson
New Thanks Scott..
And I sympathize with an apparent need to satisfy contradictory browser quirks simultaneously :[ gotta Love them innovations.

So far - seems that if I nuke WW while going to zI.. then I get login box. I tried turning it back on just After box appeared, this AM: it blinked once (to let me know I Am Being Watched) but took my ID, PW and showed "Logged in" etc.

So far soooo goooooood - and simple enough that it hardly merits any more attention (from my POV)

Everything's lookin spiffier n spiffier but not gauche, y'know :-)

(And poor ol WWasher hasn't anything to Do here! no .ocx, .vd, ad-doublepry - just spinnin its wheels an eatin up them Task cycles..)

Hey! cackle cackle: why not put in One pop-up! in random forums - fer auld lang syne? :-\ufffd

Advertisin: sex aids fer the terminally engaged, Get it? er see: sittin at a ter -



all yer base instincts blo
     Minor glitch? - (ashton2) - (21)
         PS - (ashton2) - (1)
             I lied - still broke but also no "Mark Forum Read" after ... - (ashton2)
         Might still be a proxy issue - (admin) - (5)
             OK just now.. - (ashton2) - (4)
                 PS: local timestamp now fubar != "PST" per Prefs. -NT - (ashton2) - (3)
                     YYep, there's a reason for that. - (admin) - (2)
                         Can you not use Zulu (GMT) time for all? - (a6l6e6x) - (1)
                             What I'm trying to do... - (admin)
         Would you prefer I did this by e-mail Bug report? - (Ashton) - (12)
             Nope.. Zope-zapped, zonally - (Ashton) - (1)
                 Er.. no "Mark Forum Read" etc. As follows.. -NT - (Ashton)
             Zomezing zomewat zimilarr -- - (Ric Locke) - (9)
                 This is a familiar problem. - (static)
                 Agree with Wade. - (admin)
                 One more time: - (Ashton) - (6)
                     I haven't changed anything... - (admin) - (5)
                         Ok - any clue re where to sleuth? - (Ashton) - (4)
                             Er *something* remembers I'm logged in - as THIS post - (Ashton) - (3)
                                 OK going to test forum: Tecra logs in. - (Ashton) - (2)
                                     What's going on (I think) - (admin) - (1)
                                         Thanks Scott.. - (Ashton)

He's the walking definition of Dunning-Kruger.
63 ms