IWETHEY v. 0.3.0 | TODO
1,095 registered users | 0 active users | 0 LpH | Statistics
Login | Create New User
IWETHEY Banner

Welcome to IWETHEY!

New It's too quiet in here.
So, let me tell you a story about how to fuck a Novell 3.12 server without really trying. First, some background for those of you who may not know.

I do some ocassional consulting for a community services outfit. They have 2 offices about 30 miles apart. One office (the one I usually deal with) has a Netware for Small Business 4.2 network with about 30 users. The other one (small administrative office) uses Netware 3.12 and has about 10 users.

Due to the fact that Netware 3.12 is on the discontinued list, the realization that NWSB 4.2 is headed that way, and that the DOS version of Solomon is also no longer supported, they have finally bitten the bullet and planned some major upgrades at both locations.

The office I usually deal with will be going to NW 5.1. The administrative office will be replacing the NW 3.12 server with a W2K server with SQL server so that they can run the new version of Solomon. They are also thinking about linking the 2 offices together network-wise.

So, my contact at this place calls me up and we go over a few things. Plans are laid and we agree that he & I should go to the administrative office and see what hardware they currently have, what workstations will have to be upgraded/replaced, and just what exactly is the NW 3.12 box running on.

I should probably mention at this point that I have not been doing anything at the administrative office. They have their own part-time consultant who has been extremely resistant to any changes or upgrades of any kind. In fact, this person had a hard time coming to grips with that fact that the 2GB data drive of the NW 3.12 box was nearly full, even when the server would send out broadcasts that the drive was, in fact, nearly out of space.

Anyway, we trot on up there on Friday, expecting to give our data to the "big cheese" and make our case for spending some serious cash (at least for them it's serious). Well, not everyone involved in the decision is there and we have to wait.

So, in the meantime, my contact & I decide to go down and check out the hardware in the NW 3.12 box. We figure we'll just have a look through the monitor screen and get the HD partition layouts and sizes.

The first drive we attempt to look at is the boot drive with the DOS partition. As soon as the system tries to access the drive, the server shits itself so bad that we have no choice but to power down and attempt a reboot. Well, that should have been a clue as to what was about to happen next but only after we power up the server do we see the true horror of it all.

Apparently, sometime between the last time the server was booted (about 6-7 months ago) and when we went to look at the boot drive, a very old, 1GB Micropolis SCSI HD went bad because now, although the SCSI card could tell us what brand of drive it was, the drive would not come online. This forced the system to attempt to boot from the 2GB data drive, but since the data drive only had Netware partitions (including SYS, BTW), all the system would give us was an "invalid partition table" error message. Needless to say, we both looked at each other and said "OH, SHIT!"

Well, try as we might, there was no way we were getting the server up with the Micropolis sitting there like a dead man swinging on the end of a rope. So we decided that, as a temporary fix, we'll have to install an IDE drive, re-install NW 3.12, and pray that we can get the server online without having to completely rebuild all the user accounts, printer queues, etc. We're also praying at this point that the data drive hasn't fucked itself in the process when the server died.

Well an hour later (after going to the first office and finding a 4GB IDE drive just sitting around) we're doing the 3.12 install and it actually looks like things aren't going too terribly bad. My 3.12 install skills are extremely rusty, but I'm getting through it without too much trouble and things are looking up until, after I make some final adjustments to the startup files and reboot the server for what I think will be that last time, the server complains about some corrupt volume segments on the data drive.

SHIT! I've been slaving over this thing for 4 hours and it's not going to work anyway. Just great. Well, my contact tells me, let's bag it for today (it's 5 o'clock on a Friday) and figure out something else on the way back home. I reluctantly agree, but I'm pretty upset that 1) the server shit itself in the first place, 2) it did it while I was there and the part-time consultant wasn't, 3) the guy'll probably have a shit fit for touching the box in the first place, and 4) I'll probably get blamed for the whole shit storm in the end.

Anyway, while on our way back to the first office, my contact throws out the idea of just installing NWSB 4.2 on the box and restoring from the SyQuest 250M disks that the part-time guy has been using for backups. Not the best plan, but at this point I'm open to anything so I agree that that might be the best thing to do. It only has to work for the next 3 months until they get the W2K server installed anyway.

So, that's what we decide to do on Monday morning. However, since I'm none too happy or comfortable with the server hardware we have to work with, I tell him that I'll put together a box over the weekend that we can install 4.2 on and we'll use that as a temporary box. Fine by him, as long as it works.

So, I build the box from spare parts. Not a pretty thing because I've only got IDE drives laying around, but I make sure that I'm using disk mirroring to provide some sort of fault tolerance. I do a test install of an older 4.02 version of Netware and it seems to be ok.

So, I pack it in the truck on Monday morning, drive up and meet my contact, and start the install at 9 am. Things go well. Install gets hung up on some DOS drivers I have loaded, but once I get things straightened up and restart the install, it goes in like a dream.

Attempt to do a restore of the data from the SyQuest cartridges. Damn, this is going WAY too slow. At this rate, I'll be here another 6 hours. AH! Brainstorm! I'm using an Adaptec 1522 SCSI card attached to a SCSI CDROM, so why not take the SCSI data drive out of the old server, mount the volumes that I can, and just copy over the data. Bingo! For some reason I can mount all the volumes except the old SYS partition, but everything else is there and the file copy finishes in about half an hour instead of 3 hours. Cool.

Recreate the user accounts, printer queues, and set access rights. Reconfigure the Windows boxen for NDS instead of bindery, reconfigure the network printers defined all on the Windows boxen, and test it all out. HEAVEN! Finally.

So, dear, how was your day? ;-)
New Nothing like an old fashioned nightmare
to perk up your day,
good work,
bill
tshirt front "born to die before I get old"
thshirt back "fscked another one didnja?"
New Good yarn, told well..
I mean - nice plot line, s u s p e n s e complete with [famous last words] Oh .... Shit!

While all I know about Netware is that is Has to be miles more stable and professional than BillyWare, and that they knew about networking before Billy was outta jail in Az or wherever. And they probably laughed at Win 3.11, out loud! (a good clue too - that Billy despises it, natch)

So your story called to mind -

About an hour after cadging a Tecra 700 CS off eBay, as I was going through its (however and when installed) Windoze 95, setting out to make both a boot floppy (no .docs no CDs) and see about getting the fancier Zip semi-backup to fly (maybe save Registry etc.) .. at some point on reboot got:

Ugh





Disk not found; after reboot w/floppy: no C: drive. Reset. Nada. Swear. Nada.

Oh Shit!



Well to make it less shaggy-dog - I damn well hadn't fdisked anything.. in my travels. Did a SYS from floppy - can't recall if That worked then, though. Nada. Forget how I got it to notice the C, from floppy - looked w/Norton DOS IIRC. But no boot from HD still. Grumble Speculate

So I ran fdisk /mbr with fingers crossed. Worked!

So.. what ate the boot record ?? At least your little crash had a perfectly clear reason! I hadn't screwed with later than W3.x then, so didn't know what was normal crash inducement 'cept trashing memory after x hours, or running any ap under any random condition.

Welcome to Windoze! I thought, called friend for some therapetic pins-in-Billy doll work.

Hmmm your sucker must have run *months* w/o an available boot partition! Quietly. A matter probably right over head of any old PHB, from all reports hereabouts. Yup - move to NT. Order XP tomorrow.

Anyway.. troubleshooting is itself.. fun! (if you win at least occasionally). Mine was luck.



Ashton
New <bowing> -- We are not worthy!! We are not worthy!! <grin>
Tom Sinclair
Speaker-to-Suits
     It's too quiet in here. - (n3jja) - (3)
         Nothing like an old fashioned nightmare - (boxley)
         Good yarn, told well.. - (Ashton)
         <bowing> -- We are not worthy!! We are not worthy!! <grin> -NT - (tjsinclair)

I don't even think that thing in the middle is a net.
49 ms